Unable to recover formatted hard drive Seagate 2 TB

Don't Lose Your Data Forever!

DIY data recovery has risks. You could lose your data forever! Don't want to risk it? Talk to a professional now.

romilnagrani

New member
Hello All,

Yesterday I had to format my 1.8 TB Seagate hard drive as it had occurred to me that it has lot of bad sectors. The format was successfully complete and when I tried to recover the hard drive using EaseUS data recovery software I was able to see all of the hard drive contents. I tried to recover few of the contents to another drive (partition in windows 10) but the process was extremely slow and my laptop didn't had that much of space. Hence I recover small amount of data and copied the recover data (approx. 3 GBs) into the original 1.8 TB hard drive. I also copied 3 GB of "other data" so as to check if my hard drive is able to copy-paste the data or not.

Now if I try to run same software I am unable to see old folder structure and all I see is few folders which I had copied (recover 3GB + other data of 3GB)..Previously the software used to scan 1.7 TB of recoverable data which is 100% accurate, now after scanning for an hour it shows approx. 300 GB of data of which approx. 6 GB is only useful.

How can I recover the original 1.7 TB of data? I have scan my HDD with this few softwares (each for an hr approx)

EaseUS

Mini Tool Recovery

Disk Drill

Stellar data discovery

Edit: I have now formatted the hard drive again (being impatience as always) and thus now the HDD is totally blank and hence I don't see any data now.
 
Top