How to Clone a Hard Drive With Bad Sectors Using ddrescue


New member
You should download the latest version of ssd rescue here, or click here to download SystemRescueCD, a system rescue disk for Linux that can be used as a bootable USB stick or CD.
Last edited by a moderator:


can someone write me the proper command to use if i want to make an image file of an m2 drive first (into some random folder on a USB3 external drive) and later maybe clone the image on some other m2 drive?(its not the older sata m2). and can i later mount the image file for reading and extraction too then?
i have had so many issues already that i cant even concentrate on these commands anymore lol :s

or i just enter some generic code in there and i can be sure that it doesnt write the whole external drive over with the image file?:w
Last edited:


so now i tried this a bit and immediately noticed probably the same exact stuff that i was trying to ask about...

there is no need to install hwinfo, because i got most of the very useful info with these commands:
lsblk -f
sudo fdisk -l

and if i want to get a direct copy from disk to disk, then i have to write the log file on a 3rd usb stick, which should be written as an actual mount point, not the device or disk name? (aka /media/.../rescue.log; and not /dev/sda or /dev/sda1 or anything?)

what does the -f and -d flag actually do?
and what do i do if i get some number of read errors with an ssd? did it still copy the data and then it just reports the error or did it not read it and just discarded it or smth?


okay... if this thread is actually outdated couple of yeas, can i just run a 2nd pass with superclone then? (even after rebooting?)
or use superclone to make 1 pass image file to save all files and then just use the new drive to install a fresh copy of win on it?
aparently the old one did have some bad sectors or smth...


New member
Came to issue a friendly warning.
My son's PC had a NVMe WD SN850x 4T upgrade shortly after Christmas 2022.
He recently said his machine has been acting weird, I investigate, and find the drive is having issues and has bad/unrecoverable blocks.
I had happened to buy another exact same drive during the recent Prime Day sale, so I figured we would copy his data over to the new one and RMA the old one.
Tried several different utils to copy the data, but they all kept getting stuck on the bad blocks.
Even tried CloneZilla with various expert mode settings around block mode copy and keep going after bad sectors, etc, still failed.
I saw someone mention ddrescue and figured I would give it a shot.
Found that SytemRescue was bootable and included it, so added it to my Ventoy drive, booted up, mounted one of his other drives for the log, and followed the advice here to run it.
At first it said it would take just over an hour, but once it found some bad blocks, it said 4 hours.
I went to bed.
Woke up this morning to find it was hung and on pass 3, said it had recovered 99.85% of the data, so I was thrilled.
Powered off the machine since it was unresponsive, swapped the drives around, booted, went straight to BIOS.
BIOS Said the M.2 slot was empty.
Shut it down, pulled the drive, put it in my little JMicron USB to NVMe adapter and attached it to my crappy little laptop, Unknown drive, zero bytes.
Swapped back over to his original SN850x, Unknown drive, 0 bytes.

So this process of letting it run overnight to recover the drive, has somehow killed BOTH my source and destination drive.

So I am here to issue this warning, backup anything/everything you can before running this tool.
I am kicking myself for not simply doing a robocopy or similar of as much data as I could off the drive before I started this. (IF you use Robocopy, remember to change the /R and /W settings or it will sit forever on bad files)
I figured with 13 pages in this thread, this tool was safe.
I guessed wrong.


4t = 4tb? 2tb usually takes 14-17 hours, so i would not use the systemrescue thing, if you even typed source and target the right way