Page 1 of 1

WD My Book Duo

Posted: Thu Apr 11, 2019 11:06 am
by slingshot
Hi guys, having an issue recreating the RAID out of one of these things. Drives have imaged nicely but something is getting in the way of a virtual raid reconstruction and I'm thinking it maybe down to the WD 256 bit AES hardware encryption ? Anybody able to shed any light on this one for me please ?

As always, thanks in advance for any ideas / pointers :)

WD My Book Duo

Posted: Fri Apr 12, 2019 4:47 am
by slingshot
So, these can't be recovered due to the way the encryption key is stored, great show Western Digital, great show :(

WD My Book Duo

Posted: Fri Apr 12, 2019 7:22 am
by lcoughey
No option to put clones into the enclosure or a new enclosure?

WD My Book Duo

Posted: Fri Apr 12, 2019 10:12 am
by slingshot
Unfortunately the enclosure is nuked and I'm not entirely sure if getting another one will work, as the keys are meant to be stored on the enclosures main-board :roll:

WD My Book Duo

Posted: Fri Apr 12, 2019 12:42 pm
by Jared
slingshot wrote:Unfortunately the enclosure is nuked and I'm not entirely sure if getting another one will work, as the keys are meant to be stored on the enclosures main-board :roll:
Anything on that enclosure bridge that looks like a ROM chip you could dump? I had a WD NAS that seemed to be encrypted by the bridge as well. The case was never approved so I didn't pursue it, but I seem to recall a couple ROM looking chips and I assumed the encryption key might be stored in one of those.

Sent from my SM-G935U using Tapatalk

WD My Book Duo

Posted: Sat Apr 13, 2019 1:50 pm
by slingshot
I am unable to dissemble the enclosure as its going back to customer. They seem to think they can get WD to sort it out for them :lol:

In the interests of this thing coming back (like a boomerang) once WD have taken an almighty turd on said customer, how could I dump from the chip on the controller board ?