Page 1 of 2

Samsung SP1203N Busy

Posted: Tue Jan 26, 2016 6:15 am
by pclab
Hi
I have this Samsung that is always busy.
It spins OK, no clicks, no spin down.

I get this terminal:
SpnOk
DAC:-00410
H: +00000
SK C: 0000CC03
ENG>SRV>
SvoTbl Loaded
BD
ENG>LE
E:0001 - Inv Cmd
ENG>

I don't have a donor compatible here right now, so hot-swap is not possible for now.
Any other things I could do?

Thanks

Samsung SP1203N Busy

Posted: Tue Jan 26, 2016 9:54 am
by jol
the PCB is original (ROM) and known as functional ?
have you tried a soft reset ?

Samsung SP1203N Busy

Posted: Tue Jan 26, 2016 11:28 am
by pclab
Hi Jol

Yes, PCB is original and I have also tried the soft reset.
Same thing....

Samsung SP1203N Busy

Posted: Tue Jan 26, 2016 7:21 pm
by jol
you didn't reply fully
jol wrote:Source of the post known as functional ?

one more thing
have you checked if the ROM contents isn't corrupted ?

Samsung SP1203N Busy

Posted: Wed Jan 27, 2016 3:40 am
by pclab
Oh, sorry about that.

I have read ROM, but haven't checked inside.
I will check it later.
If ROM is bad, I can write one from a donor from same family, right?
Thanks

Samsung SP1203N Busy

Posted: Wed Jan 27, 2016 9:00 am
by jol
pclab wrote:Source of the post same family, right?

same FW ver.
if you don't have, see here

Samsung SP1203N Busy

Posted: Fri Jan 29, 2016 1:08 pm
by pclab
Hey

Case update: it was the darn jumper the culprit....

Samsung SP1203N Busy

Posted: Fri Jan 29, 2016 2:01 pm
by LarrySabo
Good job figuring that out. Did that get the data back, or is that just the beginning?

Samsung SP1203N Busy

Posted: Sat Jan 30, 2016 3:55 am
by pclab
Altough the PC was flooded by water, the client (and myself to be honest) thought the HDD was bad too.
I checked PCB, it was fine, but getting that log...
After putting the jumper, I could access all data with minor bad sectors.

Samsung SP1203N Busy

Posted: Sat Jan 30, 2016 8:19 am
by LarrySabo
Which jumper, where? What was the purpose of it?