Problem with PC terminal

Don't Lose Your Data Forever!

DIY data recovery has risks. You could lose your data forever! Don't want to risk it? Talk to a professional now.

emir_has

Member
HI

I recently installed Windows 10 21H2 with all latest updates and now have problem with COM port adapter in PC-3000 7.0.30 version.
When I start utillity Seagate I cannot work with terminal even I have terminal output!
I always get this message: Software can`t control COM port signal level for this USB/COM adapter

Yes, I have tried to reinstall USB drivers, change USB cable but same situation. I use USB Terminal 2 by Acelab and also have USB Terminal 3 chines clone. Both adapters worked on WIndows 8.1.
Also:
Move PC-3000 UDMA card to new computer and same situation. Also Win 10
Reinstall Windows again on WIn 10 21H2 and now terminal shows same error but it can read in Seagate utility ROM over terminal. But when I want to for example open diag port it apply patch record back ROM but diag port is still locked!
Same message still show on initialization of seagates drive Software can`t control COM port signal level for this USB/COM adapter

Can someone help me with this problem?

Thanks
 

Jared

Administrator
Staff member
Try using an older version of the driver. I have an issue where Win 11 keeps updating the driver for the PC-3000 terminal, and then saying "it's not compatible with this version of Windows", but reinstalling the older version fixes it every time.
 

emir_has

Member
I have tried older driver from ACE Lab same issue. Also updated all drivers same thing! No Idea what to do?
I get reading in terminal can command to read ROM but when I push to write ROM back it records without error but ROM is not recorded.
Changed cables, drivers, WIndows version even computer !
 

emir_has

Member
Hi
I just want to confirm that problem indeed was with terminal boards. I have ordered new PC terminal board 3 from ACE Lab and I have received yesterday and tested it and now works. No more message "Software can`t control COM port signal level for this USB/COM adapter".
 
Top