Xela
Data Recovery Noob
Posts: 1
Joined: Tue Aug 04, 2020 5:16 pm

Recovery from taz error

Tue Aug 04, 2020 5:19 pm

I created a frankendebian by answering the distribution upgrade options incorrectly. I therefore set about to back up my home folder onto a usb drive.

In the process of trying to back up my home directory while logged in a recovery terminal, I somehow overwrote the the entire source data I was trying copy from by using tar. I do not know what command created the error as when I log back in the history is gone.

I tired to do something like this (sudo code):

tar frankendebian/home/alex -> USBDRIVE/home/backup/backup.tar

I did get the source and destination backwards, I know that much when I tried to uncompress the backed up data to verify it.

What I did do was compress USBDRIVE/home directories instead.

This did not result in the following:

frankendebian/home/alex/backup.tar along with everything else in the /home/alex directory.

Instead, the only single thing that exists in the source directory is the backup.tar file. Which contains the data from the target directory. Everything is gone.

The source data is on a solid state drive.

Is it possible to recover this data? I have been trying tools like ddresuce by copying the source volume, i have been having trouble with mounting it as i copied the whole logical group, not just the logical volume. I tried again with just the logical volume but ddresuce just reported only reading errors for 24 hours so I stopped that.

At this point I really have to put a lot of work into using the recovery tools correctly.

But I would like to know from someone wiser than me if this realistic. Is it possible to get this data back that was apparently wiped out by tar and my poor use of it. The created back.tar file was ~6Gb and there was at least this much free space in the source volume before i began the back up.

**TLDR:

Can data in a directory that has been removed by tar by recovered?**

This data is important to me.

User avatar
Jared
Forum Admin
Posts: 3917
Joined: Mon Jan 12, 2015 12:32 pm
Location: Providence, RI
Contact: Website Facebook Twitter Skype YouTube Google+

Recovery from taz error

Wed Aug 05, 2020 1:58 pm

Xela wrote:Source of the post The source data is on a solid state drive.


This is probably your problem here. Do you know if the build you are using supports T.R.I.M.?

Return to “Hard Drive Data Recovery”

Who is online

Users browsing this forum: No registered users and 0 guests